We've increased resources in a few places, and things should be running more smoothly now. We are always monitoring our infrastructure and will continue to make updates as we find areas for improvement.
Posted Sep 06, 2025 - 17:04 MDT
Monitoring
We have implemented a mitigating fix for the degraded performance affecting some RapidLMS customers. We are closely monitoring to ensure continued stability.
We will provide another update once the issue is fully confirmed as resolved.
Thank you for your patience.
Posted Sep 05, 2025 - 22:55 MDT
Investigating
We are currently investigating an issue causing degraded performance on some services. Some customers may experience slower response times or intermittent errors while using affected services.
Our team is actively working to identify the root cause and will provide updates as soon as more information becomes available.
Thank you for your patience and understanding.
Posted Sep 05, 2025 - 10:41 MDT
This incident affected: RapidLMS (RapidLMS Main Application, Nito Exam Engine).